Gateway Technical College home

System Status Page

Google Drive: Unexpected Security Verification Prompts

Resolved

Google has reported to us that this issue should now be resolved and that the security verification prompt should no longer appear.
Posted Sep 16, 2026 - 10:37 CDT

Investigating

Some users are currently seeing unexpected security verification prompts (often called CAPTCHAs) when trying to access Google Drive. These screens ask you to enter characters or select pictures to verify you are human. We are actively working with Google to resolve the issue, but it is safe to complete the verification prompt and continue working normally in the meantime.
Posted Sep 16, 2026 - 10:05 CDT
This incident affected: Google Apps (Google Apps Drive).