Page logo

Incident IQ site loading issues
Resolved
This incident has been resolved.
Posted Jan 14, 2025 - 10:03 CST
Monitoring
Monitoring - They have deployed a fix to address the slowness and page-loading issues and are currently monitoring the situation
Posted Jan 13, 2025 - 12:29 CST
Investigating
Incident IQ is currently experiencing an issue that may prevent users from accessing the site or result in blank loading pages. Their team is actively investigating the problem. We will provide updates as soon as more information becomes available.
Posted Jan 13, 2025 - 09:58 CST
This incident affected: Ticketing System (Incident IQ Platform Status Platform).