Page logo

AWS outage affecting many software applications.

Resolved

This incident has been resolved.
Posted Oct 21, 2025 - 08:13 CDT

Update

Amazon Web Services (AWS) announced that all cloud operations returned to normal late on Monday evening, after a disruption that lasted over 15 hours and heavily impacted thousands of websites and applications worldwide.
Posted Oct 21, 2025 - 08:11 CDT

Identified

Amazon Web Services (AWS) is currently experiencing a major outage. Many applications use AWS and may be experiencing outages and/or service disruptions. If you are experiencing disruptions with an application, it is likely due to this outage. We are monitoring the situation and will provide any notable updates as information becomes available.
Posted Oct 20, 2025 - 13:09 CDT
This incident affected: Brightspace / D2L.