Page logo

Network Disruptions

Identified

We have identified the issue as a fiber cut that took one of the college's Internet connections offline. We have rerouted traffic around the impacted path, and our service provider is actively working on site to repair the line.
Posted Aug 31, 2026 - 14:40 CDT

Investigating

We are currently investigating reports of network/Internet disruptions on campus.
Posted Aug 31, 2026 - 13:30 CDT
This incident affects: Internet Access / Network / Wireless.