Page logo

Ticketing System Slowness

Resolved

IncidentIQ has informed us that the issues with the ticketing system have been resolved. Please contact TechCentral at 262-564-3695 if you experience any issues accessing the ticketing system
Posted May 14, 2025 - 12:52 CDT

Identified

We are experiencing slowness and unresponsiveness on the ticketing system. This has been confirmed by Incident IQ and their engineers are currently looking into the issue for multiple customers. We will update this status once we receive an update. In the meantime, if you have a support request, please contact TechCentral at (262)564-3695.
Posted May 14, 2025 - 11:28 CDT
This incident affected: Ticketing System (Incident IQ Platform Status Platform).