Page logo

LiveChat Outage
Resolved
This incident has been resolved.
Posted May 01, 2024 - 12:30 CDT
Update
We are continuing to investigate this issue.
Posted May 01, 2024 - 12:29 CDT
Investigating
Live Chat is currently experiencing an outage. They are aware of the issue and are working to solve it. If you need IT support, please call our help desk at 262-564-3695 or submit a support ticket at gtc.incidentiq.com. If you need to get in touch with the Student Services for assistance, please call 1-800-247-7122.
Posted May 01, 2024 - 09:19 CDT
This incident affected: Chat.