Page logo

Zoom Meetings/Phone Disruptions

Resolved

Zoom is now reporting that all services have been restored.
Posted Apr 16, 2025 - 16:01 CDT

Investigating

Zoom is experiencing issues with multiple services, including meetings and phones. These disruptions may affect your Zoom experience.

We apologize for any inconvenience this may cause and appreciate your patience. Zoom is actively working to resolve the issue, we will provide status updates as they become available.
Posted Apr 16, 2025 - 14:27 CDT
This incident affected: Zoom (Zoom Zoom Meetings, Zoom Devices (Softphones/Deskphones), Zoom Zoom Phone).