Page logo

Ticketing System Outage
Resolved
Incident IQ has resolved the issue with accessing the ticketing system.
Posted Oct 01, 2024 - 12:25 CDT
Investigating
We are currently experiencing issues with submitting and reviewing tickets. Incident IQ is aware of the issue and are isolating the cause. There is currently no ETA for resolution of the issue. If you require technical assistance, please contact the Help Desk at 262-564-3695.
Posted Oct 01, 2024 - 10:44 CDT
This incident affected: Ticketing System (Incident IQ Platform Status Platform, Incident IQ Platform Status iiQ Email Processing).