Page logo

Incident IQ experiencing responsiveness issues
Resolved
Incident IQ has implemented a fix and everything seems to be working properly again.
Posted Dec 02, 2024 - 14:09 CST
Investigating
Incident IQ is experiencing some intermittent site responsiveness issues that are causing slow page loading times and intermittent login problems. They are working to rectify this. We will update this notice when we have more information. If you have a problem that you need assistance with, please call the Help Desk at 262-564-3695.
Posted Dec 02, 2024 - 10:16 CST
This incident affected: Ticketing System (Incident IQ Platform Status Platform, Incident IQ Platform Status iiQ Email Processing).