Page logo

Email and Drive documents older than 3 years old missing from Google

Resolved

Missing items from Gmail and Drive have been restored. Please contact TechCentral if you have any questions or require assistance.
Posted May 11, 2026 - 12:12 CDT

Monitoring

Gmail and Drive restore jobs have completed. We are now in the process of reviewing restore logs to identify any issues during restores.

If you have any questions or concerns, please submit a ticket at support.gtc.edu.
Posted May 05, 2026 - 10:52 CDT

Update

We have identified how to restore the email and drive documents that have gone missing (deleted). The restore process has started for email, and we are working on the drive documents now.

We expect that the email restore process will take over the weekend. When your email is restored, you may start receiving notifications on your devices for any unread emails that are restored. Please refer to this document on directions on how to silence those notifications:
https://support.google.com/mail/answer/1075549?hl=en&visit_id=639132437687611461-58510589&rd=1

Please contact TechCentral if you have any questions.
Posted May 01, 2026 - 10:01 CDT

Identified

We are aware of an issue where email and Google Drive documents older than 3 years are missing. We are working with Google to resolve this issue. We will update once we have more information.
Posted Apr 30, 2026 - 07:03 CDT
This incident affected: Google Apps (Google Apps Drive, Google Apps Gmail).