Page logo

Ticketing System Outage
Resolved
Incident IQ has applied a fix to address tickets of the customers from not loading. The ticketing system is now operational.
Posted Apr 30, 2024 - 12:26 CDT
Investigating
We are currently experiencing issues with Incident IQ. At this time, people are not able submit or review tickets. We are currently reaching out to the host provider for more information. If you need technical assistance, please contact the help desk at 262-564-3695.
Posted Apr 30, 2024 - 10:49 CDT
This incident affected: Ticketing System.