Page logo

Zoom Login Issues/Slowness

Resolved

Zoom is now reporting this incident as resolved.
Posted Jun 22, 2026 - 11:51 CDT

Investigating

We are receiving reports of intermittent login failures and slowness with Zoom. Our team is actively investigating the issue and will provide updates as they become available.
Posted Jun 22, 2026 - 09:26 CDT
This incident affected: Zoom (Zoom Zoom Meetings, Zoom Zoom Phone).