Page logo

Google Workspace Service Disruption

Resolved

This incident has been resolved.
Posted Jul 18, 2025 - 12:14 CDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 18, 2025 - 11:07 CDT

Update

Google is reporting the incident as resolved, we are currently monitoring.
Posted Jul 18, 2025 - 11:07 CDT

Identified

Google Workspace is currently experiencing issues affecting multiple services, including Gmail and Google Drive. Some users may encounter disruptions when trying to access these services.

We apologize for any inconvenience this may cause and appreciate your patience as Google works to resolve the issue. We will provide updates as more information becomes available.
Posted Jul 18, 2025 - 10:47 CDT
This incident affected: Google Apps (Google Apps Drive, Google Apps Gmail, Google Apps Google Drive).